Microtik
อธิบายขั้นตอนการตั้งค่า Microtik router เพื่อใช้งานร่วมกับ Seara Cloud

วิธีการ Config Interface + DHCP

1.ทำการสร้าง interface ที่ต้องการใช้งาน ในตัวอย่างจะสร้าง interface bridge แล้วผูกขา eth2 3 4 เข้ามาใน Bridge โดยตั้งชื่อว่า bridge-LAN
*หากไม่ต้องการใช้ bridge interface สามารถใช้ eth2 , eth3 , eth4, eth5 ได้เลย และทำการตั้งชื่อตามที่ต้องการ
Bridge
2.ทำการกำหนดค่า IP Address ของชุด IP ที่ต้องการใช้ ในตัวอย่าง จะให้วง Client LAN ที่ใช้เป็น Ip address 192.168.200.1/24
Network id 192.168.200.0
ผูกกับขา bridge-LAN
IP > Address List
3.ทำการกำหนด IP DHCP Server Pool ที่ใช้แจกให้กับ Client โดยผูกกับ bridge-LAN
IP > DHCP Server
ทำการทดสอบ DHCP จากเครื่อง PC Computer ต้องได้ IP ตามที่กำหนดใน Mikrotik ตามภาพ

การทำ NAT ให้ LAN

Chian : srcnat
Action : masquerade
IP > Firewall > ให้เลือกไปที่ TAB NAT แล้วสร้าง ใหม่

การ Setup Radius Server

Service : hotspot = On Address : 209.97.169.126 Secret : เช็คในอีเมลล์ สำหรับ Secret Key Authentication Port : 1812 Account Port : 1813 Timeout : 9000Radius >
ทำการสร้าง Hot Spot Server NAME : ให้เอา system identity มาใส่ interface : bridge-LAN ที่เรานั้นได้สร้างเอาไว้ Address pool : ให้แจก ip pool ตามที่เราสร้างไว้ในขั้นตอน DHCP Server profile : default Login : ให้เลือก HTTP PAP Radius : เลือก Use Radius
ติ๊ก Use RADIUS และ interim Uptime : 00:01:00 Login by : HTTP PAP
User Profiles > ในหัวข้อ Shared User : ต้องไม่ใส่ ให้เป็นค่าว่าง

การ Setup Wallgarden

นำ Script Wallgarden , FB , Line มาใส่
######### Line ACL List Allow ######### /ip firewall address-list
add address=terms.line.me list=Trusted-Line
add address=line.me list=Trusted-Line
add address=d.line-scdn.net list=Trusted-Line
add address=access.line.me list=Trusted-Line
add address=static.line-scdn.net list=Trusted-Line
add address=profile.line-scdn.net list=Trusted-Line
######### FB Wallgarden #########
/ip hotspot walled-garden
add dst-host=*.facebook.com
add dst-host=*.facebook.net
add dst-host=*.akamaihd.net
add dst-host=*.digicert.com
add dst-host=*.fbcdn.net
add dst-host=*.fb.com
add dst-host=*.fbsbx.com
add dst-host=*.facebook.com
add dst-host=*.facebook.net
add dst-host=*.akamaihd.net
add dst-host=*.digicert.com
add dst-host=*.fbcdn.net
add dst-host=*.fb.com
add dst-host=*.fbsbx.com
### Youtube Wallgarden #########
/ip hotspot walled-garden
add dst-host=.youtube.com
add dst-host=.ytimg.com
add dst-host=.google.com
add dst-host=.googlevideo.com
System > Script : *หลังจากใส่เรียบร้อยแล้วให้กด Run Script ทั้ง 2 อัน สร้าง จำนวน 2 Script Facebook , Line
Wall garden 1 : ชื่อdomainของคุณ.seara-portal.net
Wall garden 2 : ACL List Line
** แต่เมื่อทำ ACL Trusted Line เสร็จเรียบร้อยให้ไปที่หน้าต่าง Wall Garden แล้วทำการลบ Allow ของ ACL นี้ออก

Upload Code login.html & alogin.html

ไฟล์ alogin.html และ login.html หลังแก้เสร็จแล้วให้ Upload กลับเข้าไปเหมือนเดิม path เดิม ให้แก่ตาม Domain แต่ละไซต์ ที่ใช้ ตรง location.herf
login.html
alonin.html
login.html
948B
Text
alogin.html
1KB
Text

ตั้งค่าการส่ง Internet Traffic Log จาก Microtik ไปยัง Seara

  1. 1.
    ตั้งค่าการส่ง Hotspot Login , Logout โดยกำหนด ตั้งค่าที่ IP->Hotspot->UserProfile->Script
On Login
:local whouser $user;
:local whoip $address;
:local macaddr [/ip hotspot active get [find user=$whouser] mac-address];
:log info ("User Login: ".$whouser." IP: ".$whoip." MAC: ".macaddr);
On Logout
:log info ("User Logout: ".$user);
2. ตั้งค่าการส่ง Internet Traffic Log โดยกำหนดจาก Rule Firewall ดังนี้ system ->Logging->New Rules
โดยจะต้องสร้าง 3 Rules ดังนี้
การตั้งค่าการส่ง Hotspot และ Internet Traffic Log

Logging
Data
Rule1:Topic
hotspot,Script,!debug
Rule2:Topic
firewall,!debug
Rule3:Topic
script,info
Prefix
SEARA-{MAC Address ของอุปกรณ์}
Action
Seara Log
3. ตั้งค่า Syslog Server ที่จะรับ Traffic จากระบบ System->Logging->Action
การตั้งค่า Syslog Server
Name : SearaLog
Type : remote
Remote Address : 159.65.131.164
Remote Port : 514
** IP ของ Remote Address อาจจะมีการเปลี่ยนแปลงตาม Domain ที่สร้างให้ตรวจสอบจากเจ้าหน้าที่อีกครั้ง
4. กำหนด Allow Firewall สำหรับ ส่ง Log ไปยัง syslog server IP->Firewll->Filter Rules
การตั้งค่า Policy บน Firewall สำหรับ allow Log traffic
Rule 1
Data
General
Chain: Forward
Protocol:udp
Out. Interface:{ขา WAN ออก Internet}
Action
Action:Log
Enable:Log

Rule 2
Data
General
Chain: Forward
Protocol:udp
Action
Action:Log
Enable:Log

การผูก Mikrotik เข้ากับ Seara

นำ identity ของ Mikrotik ไปผูกกับ Seara System > Identity

การสร้าง หน้า portal Login Hotspot > จากนั้นตั้งชื่อให้เหมือนกับ Interface NAME ของ Mikrotik : bridge-LAN